OnSite Help Center

IMPORTANT

Lightspeed OnSite uses a root certificate to establish a secure connection between the server and the client. The original certificate included in OnSite at its release has a 10-year lifespan which will expire on July 22nd, 2019. In order to continue using Lightspeed OnSite after that date, you'll need to update this certificate.

Welcome to OnSite!

Here you’ll find everything you need to know about Lightspeed OnSite, including installing and setting up OnSite, creating/importing your product inventory, making sales and processing returns, generating reports, and more.

Family_on-site.png

Use the left menu to navigate through the OnSite Help Center and explore topics. Or, use the searchbar to look for specific information.

Getting in touch with Technical Support

Still not finding the information you need? No worries! Our Support team is available to help you 24/7 and you can contact them in a few different ways:

  • Start a chat
  • Submit a request (email)
  • Request a callback
  • Call our Retail Support phone line

For specific instructions and contact information, please see our Contact us article.

IMPORTANT

Be advised that macOS 10.14 (Mojave) is only compatible with Lightspeed OnSite version 2019 1.0.0 and later. We recommend upgrading Lightspeed OnSite to at least 2018 3.0.3 before updating your operating system to macOS 10.14. If you are several Lightspeed OnSite releases behind and would like to update to macOS 10.14, we recommend updating your operating system and Lightspeed OnSite as follows:

  1. Ensure macOS is updated to 10.12
  2. Upgrade Lightspeed OnSite to 2018.3.0.3
  3. Update macOS to 10.14 (Mojave)
  4. Upgrade Lightspeed to 2019.1